Opened 4 years ago

Closed 4 years ago

#52 closed bug (fixed)

map screenshot not being generated properly (randomly)

Reported by: borja Owned by: borja
Priority: major Milestone: OpenWorkouts 0.1
Component: maps Keywords:
Cc:

Description (last modified by borja)

Basically, some times it seems chrome takes the screenshot before the map is fully loaded, which ends in maps like this:

map generated on staging.openworkouts.org

Which are totally useless.

We need a way to reliable generate those maps.

(hint: maybe look into how to make chrome wait for the map to be loaded?)

Attachments (1)

1.png (404.5 KB) - added by borja 4 years ago.
map generated on staging.openworkouts.org

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by borja

map generated on staging.openworkouts.org

comment:1 Changed 4 years ago by borja

  • Description modified (diff)

comment:2 Changed 4 years ago by borja

  • Owner set to borja
  • Status changed from new to accepted

comment:3 Changed 4 years ago by borja

Fixed here: changeset:d6f8304/OpenWorkouts-git, changeset:02aee97/OpenWorkouts-git and changeset:b3374f6/OpenWorkouts-git

The temporary image we do use as a placeholder when no screenshot is available could be improved though, look into ticket #55 for that.

Last edited 4 years ago by borja (previous) (diff)

comment:4 Changed 4 years ago by borja

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.